Po podłączeniu kabla sieciowego rozłącza internet po wifi.

Witam. Posiadam w domu 4 komputery. Wszystkie łączą się z internetem po wifi. Na każdym z nich mnóstwo śmieci w postaci filmów muzyki itp. Dlatego postanowiłem postawić serwer na linuxie na którym będę przechowywał wszystkie pliki multimedialne. Wszystkie 4 komputery będą podłączone do tego serwera przy pomocy kabla sieciowego. Na linuxie skonfigurowałem sobie już połączenie przy pomocy dnsmasq dzięki czemu adresy ip są przydzielane automatycznie i nie muszę nic grzebać w windowsie i sam robić przydziałów ip. Wszystko fajnie, komputery się widzą, pingują się tylko problem pojawia się gdy podłączę kabel sieciowy do gniazda ethernet komputera gdzie jest windows. Normalnie łączy się on z internetem po wifi. Gdy podłącze kabel sieciowy automatycznie rozłącza mnie z internetem. Wifi jest połączone, siła sygnału ok ale wyjścia na świat nie mam. Odłączam kabel i internet powraca ale wtedy z kolei nie mam łączności z komputerem z linuxem. Czy ktoś wie co jest grane? Byłym wdzięczny za pomoc.

Odpowiedzi: 5

Nie powinno a pomogło ;). Super. Wielkie dzięki za pomoc. Nawet znajomy który jest z zawodu sieciowcem nie wiedział jak mi pomóc. Teraz wszystko jest tak jak powinno. IP się przydziela z automatu, komputery się pingują a internet działa. Jeszcze raz dziękuje :):)
lukpio3
Dodano
2011-06-11 14:34:28
Znajdź fragment [code]# Override the default route supplied by dnsmasq and send no default # route at all. Note that this only works for the options sent by # default (1, 3, 6, 12, 28) the same line will send a zero-length option # for all other option numbers. #dhcp-option=3[/code] i odkomentuj jego ostatnią linię. Powinno pomóc.
BlaSOFT
Dodano
2011-06-11 12:58:15
[color=darkred]lukpio3 - Proszę o przyjęcie takiej formy dodawania logów :)[/color]
XanTyp
Dodano
2011-06-11 11:37:45
Przepraszam, nie zdążyłem napisać ale kolega jest jasnowidzem :). Oczywiście masz rację. Jak mam podłączone tylko wifi to mam adres bramy 192.168.1.1. Gdy podłączam kabel to dla nowego połączenia mam nowy adres bramy 192.168.0.1. Jak wiadomo 2 adresy być nie mogę bo pakiety nie widzą jak mają wędrować przez co rozłącza internet. Zapytam Cię bo może wiesz, gdzie i jak w dnsmasq skonfigurować to aby nie wysyłało adresu bramy? Bo przyznam się że nie za bardzo wiem. Oto zawartość mojego pliku dnsmasq.conf: http://www.wklejto.pl/99381
lukpio3
Dodano
2011-06-11 02:05:42
Prawdopodobnie po podłączeniu kabla ethernetowego w Windowsie przestawia Ci się adres bramy domyślnej. Jeżeli ten linuksowy serwer dla pozostałych komputerów nie pełni funkcji routera, możesz bez negatywnych konsekwencji skonfigurować dnsmasq tak, żeby przez DHCP nie wysyłał adresu bramy domyślnej.
BlaSOFT
Dodano
2011-06-11 01:56:46
lukpio3
Dodano:
2011-06-10 19:49:36
Komentarzy:
5
Strona 1 / 1